My 12v battery does not hold a charge, what do I do?

Follow

Comments

8 comments

  • Avatar
    Jorge Rodriguez

    My Lithium Ion Battery packed (UN3481) Section II stopped working and will no longer charge.I have 2 one when plugged in turned the light on the charger red when charging and the one that's not working keeps the light green .what should I do?

    1
    Comment actions Permalink
  • Avatar
    Paulnptld

    One of my batteries has failed as well. I've only had it for 10 months, and it's been used a handful of times. It took a charge last week then abruptly stopped. 

     

     

     

    1
    Comment actions Permalink
  • Avatar
    Jamual harris

    I just bought this shit charged it like you said and the crap still won’t work. Even the charger is finicky. Like I’ll plug it up and it will just stop charging if the table gets bumped. All the leds are lit up yet it dies. Wtf

    0
    Comment actions Permalink
  • Avatar
    Jamual harris

    Why did u guys go with a proprietary freakin battery?! At least make sure your shits solid if you go that route.

    0
    Comment actions Permalink
  • Avatar
    Viveack “Vick” Yogeswaran

    Hey Jamual,

    I understand your frustration very well, I waited excitedly to test out my jacket and its heating functions. Only to find that it wasn't holding charge, however I reached out to the support team and they mentioned this was an issue only from the recent shipment. The supplier apparently sent a batch of corrupt batteries, please contact support and they should be able to solve it. I am still waiting on my replacement battery since last week of November.

    Hope this helps, rest assure I still have hope in this product.

    0
    Comment actions Permalink
  • Avatar
    Jamual harris

    Naa I’m good, about to return it right now.

    0
    Comment actions Permalink
  • Avatar
    Paulnptld

    Hi Ezra and team Ravean,

     

    I have two battery packs that have failed under minimal use. Purchase was in January. The third pack seems to be working fine. I have three chargers as well, so that's not the issue (though the connector on one charger is rather finicky).


    Guessing you got some bad lithium cells from China.

    I know things are jammed up right now, but is there a simple way for me to repair these on my own? If these are 18650s, I'm happy to break the case open and swap them out for something reliable on my own dime. Can that be done?

    0
    Comment actions Permalink
  • Avatar
    Larry Leonard

    Bought coat as present for wife and when I tried it to make sure it worked, it didn't.  Battery charges and shows all leds lit, yet when connected to coat right after charging the coat button lights up and dims as its supposed to, but the light on button goes off quickly and no heat to coat yet the battery still shows all leds lit as if its fully charged.  When unplugged and plugged back into coat the jacket light does not come back on unless I recharge the battery then same thing happens.  Also, how do you control the zones and power level for heating? 

    0
    Comment actions Permalink

Please sign in to leave a comment.